[netflow-tools] "Fatal error - exiting immediately"

Damien Miller djm at mindrot.org
Thu Nov 17 11:17:02 EST 2005

On Thu, 17 Nov 2005, Tony and Robyn Lewis wrote:

> Have just come across softflowd, and am trying to get it working.
> When I run it, i get a fatal error:
> me at mymachine:~/softflowd-0.9.7$ sudo ./softflowd -i eth0
> -nlocalhost:2055 -d -D
> softflowd v0.9.7 starting data collection
> Exporting flows to []:2055
> Fatal error - exiting immediately

That indicates a malloc() failure usually. Are you running with tight 

> Exiting immediately on user request
> I had a quick poke in the code, but nothing jumped out.  I can see where
> the error is reported, but it looks like it's generated in the big
> for(;;) loop.
> I'm using libpcap0.8 headers, though I tried it with libpcap0.7 too.
> The following tail end of strace output might yield clues:

Do you have ltrace or any tools that can trace system library calls? That 
would probably be more useful.

If you want to dive into the code, search for return(PP_MALLOC_FAIL) 
statements and insert some logging around them so you can see exactly 
which allocation failed.


More information about the netflow-tools mailing list