[Bug 882] Scp cannot copy self-referring directories

bugzilla-daemon at mindrot.org bugzilla-daemon at mindrot.org
Wed Jun 23 16:00:13 EST 2004


           Summary: Scp cannot copy self-referring directories
           Product: Portable OpenSSH
           Version: 3.8p1
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: major
          Priority: P2
         Component: scp
        AssignedTo: openssh-bugs at mindrot.org
        ReportedBy: creidieki+sshbugs at gmail.com


I was trying to copy a directory from my school web space, and there was a link
in the directory that led back to the directory itself.  When I tried to scp
this directory to my home computer, scp tried to create an infinite number of
copies of the directory!  It was someone else's directory, so I couldn't just
delete the link.  The directory worked fine with "cp -r", but not with "scp -r".

I could provide a sample of this kind of directory if that would be helpful.


------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the openssh-bugs mailing list