[Bug 1607] New: compile errors buliding OpenSSH for older Red Hat

bugzilla-daemon at bugzilla.mindrot.org bugzilla-daemon at bugzilla.mindrot.org
Fri Jun 12 05:12:01 EST 2009


           Summary: compile errors buliding OpenSSH for older Red Hat
           Product: Portable OpenSSH
           Version: 5.2p1
          Platform: ix86
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Build system
        AssignedTo: unassigned-bugs at mindrot.org
        ReportedBy: adam at irvine.com

A couple problems building OpenSSH 5.2p1 on an older RedHat Linux
system (6.2).  Both of these could probably be easily fixed in the
configuration script.

(1) My version of /usr/include/netinet/in.h did not define in_port_t,
    causing compiler to fail on channels.c line 2472.  Worked around
    by changing in_port_t to uint16_t on that line.

(2) sftp-server.c line 507

    buffer_put_int64(&msg, FSID_TO_ULONG(st->f_fsid));

    got "incompatible type" error.  FSID_HAS_VAL was not defined:

        checking if f_fsid has val members... no

    causing FSID_TO_ULONG to be defined in defines.h:

         # define FSID_TO_ULONG(f) ((f))

    but I don't see how this could work---was it intentional that
    sftp-server.c would get an error if this was not defined?  Or was
    it expected that f_fsid would itself be a 64-bit integer in that
    case?  In any case, __fsid_t is defined like this in
    <bits/types.h> on my system:

        typedef struct
            int __val[2];
          } __fsid_t;            /* Type of file system IDs.  */

    and I worked around it by copying the "good" definition of
    FSID_TO_ULONG in defines.h and changing val to __val.

Configure bugmail: https://bugzilla.mindrot.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching the assignee of the bug.

More information about the openssh-bugs mailing list