[Bug 2428] realpath command doesn't work

bugzilla-daemon at mindrot.org bugzilla-daemon at mindrot.org
Thu Jul 16 07:03:23 AEST 2015


--- Comment #6 from David Kahles <david.kahles96 at gmail.com> ---
Thank you for the patch, it changes config.h to contain
but unfortunately it still doesn't work. There seems to be a linker
problem. The openbsd realpath function gets build (I checked it with a
#pragma message), but it seems as the libc version gets linked. I
copied the openbsd function, renamed it and executed it when the libc
function failed, and the result was as expected: the openbsd function
didn't fail.
But I wonder why the libc version gets linked, as the openbsd one
should overwrite it? I attach the Makefile, but it seems to be right.
I tried it also with gcc 4.9.2 - no difference.
Do you have a clue what's going wrong?

PS: of course I reconfigured and rebuild the whole project after
applying the patch.

You are receiving this mail because:
You are watching someone on the CC list of the bug.
You are watching the assignee of the bug.

More information about the openssh-bugs mailing list