[Bug 2765] ssh-copy-id appears to hang indefinitely when the target user has no password

bugzilla-daemon at mindrot.org bugzilla-daemon at mindrot.org
Wed Nov 22 23:47:57 AEDT 2023


--- Comment #2 from ymbirtt at gmail.com ---
So, I still occasionally get emails about this and keep meaning to come
back to it and here I am. I've just tried to reproduce this using the
version of ssh-copy-id in openssh-client-1:8.2p1-4ubuntu0.9, and
couldn't any more.

In particular, it seems as though this newer ssh client won't
successfully create a session with someone who has no password - I
still get prompted for a password, but since no password is defined I
can't successfully authenticate.

Though being prompted for a password against a user who has none still
feels like slightly odd behaviour, I'm happy that this bug is no longer

Thanks for keeping the ticket open all this time :)

You are receiving this mail because:
You are watching someone on the CC list of the bug.

More information about the openssh-bugs mailing list