status of openssh for solaris?

Niels Provos provos at
Tue Nov 23 03:33:44 EST 1999

In message <19991122110826.A23851 at>, Willard Dawson 
>I just tried to compile, this time with openssh-1.2pre14, openssl-0.9.4
>and egd-0.6.  I get considerably further along, but still not completely
>compiled.  Here are the last bits:
>gcc -g -O2 -Wall -I/usr/local/ssl/include -DETCDIR=\"/usr/local/etc\" -DSSH_PR
>OGRAM=\"/usr/local/bin/ssh\" -DASKPASS_PROGRAM=\"/usr/local/libexec/ssh/ssh-as
>kpass\" -DHAVE_CONFIG_H  -c  bsd-daemon.c
>bsd-daemon.c: In function `daemon':
>bsd-daemon.c:70: `_PATH_DEVNULL' undeclared (first use in this function)
>bsd-daemon.c:70: (Each undeclared identifier is reported only once
>bsd-daemon.c:70: for each function it appears in.)
>*** Error code 1
>make: Fatal error: Command failed for target `bsd-daemon.o'
>I cannot find any reference to DEVNULL in /usr/include or .../sys.  This
>must be a bsd-ism, not supported under native Solaris, I guess.
Okay, I cc'ed this to the openssh-unix-dev mailing list.

It should just be like this:

/usr/include/paths.h:#define    _PATH_DEVNULL   "/dev/null"


More information about the openssh-unix-dev mailing list