logout() returned an error

Tobias Klein tklein2 at ix.urz.uni-heidelberg.de
Mon Jul 17 19:55:34 EST 2000

Hi everybody,

I got the following problems, as I tried to connect from ssh (1.2.27) client
to openssh (2.1.1p4) server:

$ ssh -l user1
user1 at's password:
Last login: Mon Jul 17 11.05.44 2000 from
-bash: úPtty3: command not found
-bash: Zg9tty3: command not found
connection to closed.


Jul 17 11:10:40  nec  xinetd[7877]: START: ssh pid=7975 from=
Jul 17 11:10:40  nec  sshd[7975]: Generating 1152 bit RSA Key.
Jul 17 11:10:40  nec  sshd[7975]: RSA key generation complete.
Jul 17 11:10:40  nec  sshd[7975]: Accepted password for user1 from port 1023
Jul 17 11:10:43  nec  PAM_pwdb[7975]: (sshd) session opened for user user1
by (uid=0)
Jul 17 11:10:43  nec  sshd[7975]: syslogin_perform_logout: logout() returned
an error
Jul 17 11:10:53  nec  PAM_pwdb[7975]: (sshd) session closed for user1.
Jul 17 11:10:53  nec  xinetd[7877]: EXIT: ssh pid=7975 duration = 13 (sec)

any hints on this?
As I tried to connect from the openssh-client to the ssh-(1.2.27)-server,
then everything seems to work correctly. Hm.

Thanx in advance,

More information about the openssh-unix-dev mailing list