Config problem Solaris 2.7

Johannes Gritsch j.gritsch at
Wed Mar 15 02:59:02 EST 2000

Hi all!

I think I uncovered a kind of bug in the configuration file, but it may
be related to my specific configuration. 

Anyway, I tried to install the latest version on our Sun Sparc, running
Solaris 2.7 with gcc 2.8.1. I ran configure with --with-egd-pool
--prefix=/usr/local. When I finally started make gcc failed with some
strange error message (see attachement). 

When I tried to track down that error I found the following in my
CFLAGS=-g -O2 -I/usr/local/include -I/usr/include
-I/usr/local/openssl/include -I/usr/lib/openssl/include
-I/usr/local/ssl/include -I/usr/local/ssl/include

The problm seems to be "-I/usr/include". IMHO a rather redundant entry,
after removing it, openssh compiled beautifully. I have no idea behind the
intention of including those standard files, maybe they are needed in 
machines running both cc and gcc.

At least in Solaris 2.7 wiht gcc only it´s necessary to suppress that
entry in Makefile.

best wishes


Johannes Gritsch
Unix Consultant
Windschnur, Austria

Sent through GMX FreeMail -
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: errlog

More information about the openssh-unix-dev mailing list