A Heisenbug?

Gary Algier gaa at ulticom.com
Tue May 16 05:00:31 EST 2000

I am trying to run OpenSSH 2.1.0 on Solaris 2.6.  It seems to have what
I call a Heisenbug.  It only fails as long as you are not looking at it:

	1) I run it as "sshd -f /etc/some-config-file".
	   I can login, a "ps -ef | grep sshd" shows the parent and
	   the child.  When I exit, the child dies, but so does the
	2) I run it with "sshd -d ..." and this tells me nothing.
	3) I "truss -f -p ..." the running parent and I see that it
	   seems to do an "exit(0)".
	4) I use gdb and attach to the running parent and IT WORKS

Every sshd running under gdb works fine, every sshd started normally
dies.  I guess I need to start sshd with gdb every time ;-).

Any ideas?

Gary Algier, WB2FWZ       gary.algier at ulticom.com           +1 856 787 2758
Ulticom Inc., 1020 Briggs Rd, Mt. Laurel, NJ 08054      Fax:+1 856 866 2033

            This space intentionally left blank by the censors.

More information about the openssh-unix-dev mailing list