openssh-2.3.0p1-1 with RedHat 6.2 - Bad packet length

Peter Stuge stuge at
Thu Nov 9 10:46:49 EST 2000

On Wed, Nov 08, 2000 at 11:06:30AM -0700, James wrote:
> I haven't been able to get scp to work with RedHat 6.2 (select: Bad file
> descriptor), so...  I tried upgrading with openssh-2.3.0p1-1.src.rpm and
> openssl-0.9.5a-3.src.rpm  No joy.  When running just ssh, I get
> "Disconnecting: Bad packet length 795178083."
> This seems to be a problem with sshd, since the 2.3 ssh client will work
> fine with a 2.1 server (but not scp, which still gives "select: Bad file
> descriptor".
> Any suggestions?

I've gotten the "select: Bad file descriptor" from not having the binary scp
in the PATH that sshd sets on the server side when my scp running ssh
connects.  This error message should probably be made more informative.

About the "Bad packet length" I've only gotten that when trying to play with
F-Secure SSH.  I solved this problem by surrounding myself with mostly


irc: CareBear\    tel: +46-40-914420
irl: Peter Stuge  gsm: +46-705-783805

More information about the openssh-unix-dev mailing list