HPUX: ssh hangs after shell exit

Aaron Bush abush at microcenter.com
Wed Jun 6 07:30:45 EST 2001

I am aware that there have been several posts related to ssh connections
hanging, i have tried to read through most of them in the archives... I
am posting this in hopes that it may present something new that will
further help resolve this problem.

The problem i am having appears to be similar to what others have
reported where after typing exit in an interactive shell the connection
is not closed unitl an additional _one_ key stroke is issued (space-bar,
enter, etc...).

The sshd server is OpenSSH_2.9p1 on HPUX-11.00.  I have tried connecting
using the OpenSSH_2.9p1 ssh client from Linux-2.4, HPUX-11.00 and
FreeBSD-4.2.  The behavior so far is _always_ consistent:

1) establish connection to sshd using ssh simply via "ssh remote-host"
2) type exit in interactive shell on remote-host.
3) "logout" is echoed to the terminal and the local shell prompt is NOT
4) type any other key, usually i just hit the space-bar. <<--PROBLEM IS
5) "Connection to remote-host closed." is echoed to the terminal
followed by the local shell prompt.

If i do a ps from another session on the remote-host (HPUX-11.00) before
doing step 4 from above (hitting space-bar) this is what i see
(cleaned-up to removed non-related processes):
sysadm$ ps -ef|grep abush
    root 20088 15876  0 17:49:31 ?         0:00 sshd: abush at 4
   abush 20090 20088  0 17:49:32 ?         0:00 <defunct>

An additional problem that appears to be realted to this is (but does
not happen 100% of the time) is that a scp of a file from a HPUX-11.00
sshd server will hang indefinitely.  Looking at the same ps output will
show the same <defunct> process again.

The problem is only seen when the sshd server is running on HPUX,
connections betweeen other hosts respond as expected.

I can also provide output from sshd -d and ssh -v -v -v if needed and
anything else that might help to clear this up.


More information about the openssh-unix-dev mailing list