ssh & pipe

Philip Spencer pspencer at
Sat Jun 16 04:48:02 EST 2001

Sorry, I forgot to include the -n flag in my examples.

Previous pipe problems in openssh were indeed cured by adding -n as
you suggest, but this current problem is occurring even with the -n option.

Thanks for the reminder, though. The -n was in the original script that
was failing, but I forgot it when generating the test-case examples.

But alas, even with the -n the test-case examples still fail. :(

- Philip.

On Fri, 15 Jun 2001, John Dunlap wrote:

> > We recently tried upgrading openssh from 2.5.2p2 to 2.9p1
> > and discovered that it no longer worked to feed the output from a remote
> > command into a pipe, unless the output was short and the pipe was very
> > fast at processing its input.
> > Example 1:    ssh remote_machine some_command | less
> I cured this by adding -n to the ssh options:
> ssh -n remote_machine some_command | less
> --
> John Dunlap                           University of Washington
> Senior Electrical Engineer            Applied Physics Laboratory
> dunlap at             1013 NE 40th Street
> 206-543-7207, 543-1300, FAX 543-6785  Seattle, WA   98105-6698

Philip Spencer  pspencer at | Director of Computing Services
Room 336        (416)-348-9710  ext3036     | The Fields Institute for
222 College St, Toronto ON M5T 3J1 Canada   | Research in Mathematical Sciences

More information about the openssh-unix-dev mailing list