openssh-2.5.1p[1,2] and scp-problems on Solaris7

Jürgen Ellinger ellinger at
Wed Mar 7 04:03:21 EST 2001


I'm not subscribed to that list, so please keep me in cc, if you decide
to answer my question

I'm trying to compile and install openssh for some solaris7-machines.
Everything works fine, but I'm continuously failing to connect openssh's
sshd with scp:

 I've tried openssh-2.5.1p1: the daemon died with signal 11 (SIG_SEGV) - 
sure I've read the hint on that list 
and with the described workaround the daemon no longer crashes - but
the whole transaction hangs. In the meantime openssh-2.5.1p2 appeared
I tested, whether the problems are fixed in this version. Without any
patch the daemon does not crash, but the communication still is hanging.
The daemon starts a shell, the shell execs a 'scp -t <filename>' and
nothing happens. A traceback of the running process (done with Solaris
proctool) shows, that scp seems to block while reading (from a socket,
I suppose). I tried to contact the server with several implementations
of the client (linux, solaris, ssh, openssh etc), but I cant get the
stuff working.

So if anybody on the list has an helpful hint I would be very happy.
Feel free to ask if you need more information about config params or
something like that.

Thanks in advance!


Jürgen Ellinger
Siemensstraße 44
D-88250 Weingarten, Germany

ellinger at

More information about the openssh-unix-dev mailing list