Antw: Ctrl-C problem on HP-UX

Stephan Hendl Stephan.Hendl at
Wed Mar 14 23:19:09 EST 2001

Hi Ryan,

I run into the same problem with my HP-UX 11 as well as HP-UX 10.20 boxes. Therefore I decided not to start the sshd from the swagent in the postinstall script. I start the daemon via the lan console by hand. I know in large environments it is not a perfect solution but the only one which works these days ;-((


LDS Brandenburg
Dr. Stephan Hendl
fon: +49-(0)331-39 471
fax: +49-(0)331-27548 1187
EMail: stephan.hendl at

>>> Ryan Bradetich <ryan_bradetich at> 03/14 12:27  >>>
Hello OpenSSH Developers,

I have been working on developeing an OpenSSH SD package for
HP-UX 10.20 and HP-UX 11.00 to deploy on servers we manage.  
Unfortenately, I have enountered the ctrl-c problem which
manifests when the daemon is started in non-interactive
mode (in this case from the SD Daemon).  When I manually
stop/start the daemon, the ctrl-c functionality works.  

I have dug through the archives and found the work Garrick
James, Gert Doering, and Damien Miler have done in the 
past to fix this problem.  Verified the signal(SIGINT, SIG_DFL);
was in the proper place in the sshd.c.  Then I tried the fix
Garrick James and Gert Doering origionally propsed by adding the
signal to sshpty.c.  Neither of these solutions solved the

I have tested this on both openssh-2.3.0p1 and openssh-2.5.1p1,
connecting from a linux/hp-ux system using openssh-2.3.0p1 
protocol 1. I have not tried protocol 2 at this time, but would 
be willing to test this if it helps debug the problem.

Please let me know if I can provide more information/test ideas,
etc.  I would really like to find a [better] fix for this 


- Ryan

P.S. Please CC me on the email since I am not subscribed to this
list (yet).

Ryan Bradetich
Siteminder Support
Linux Platform Support

More information about the openssh-unix-dev mailing list