linux X forwarding still not working

Pekka Savola pekkas at
Wed Mar 21 01:21:37 EST 2001

On Tue, 20 Mar 2001, Kevin Taylor wrote:

> I'm now using the openssh-2.5.2p1 version, and the X forwarding on the
> linux machine is still not working.
> It's a Redhat 6.2 machine running kernel 2.2.17-14
> It doesn't appear to be adding anything to the /tmp/ssh-whatever/cookies
> file when you log in.
> I posted some debug info yesterday.
> Does anyone have some ideas of what I can try next, or is this a known
> bug?

I just tested openssh-2.5.2p1 from RHL7 to openssh-2.5.2p1 RHL62 and X
forwarding works fine.

For the record, how it was compiled (on RHL7):

OpenSSH configured has been configured with the following options.
                 User binaries: /usr/bin
               System binaries: /usr/sbin
           Configuration files: /etc/ssh
               Askpass program: /usr/libexec/openssh/ssh-askpass
                  Manual pages: /usr/share/man/manX
                      PID file: /var/run
        sshd default user PATH: /bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
      Random number collection: Device (/dev/urandom)
                Manpage format: man
                   PAM support: yes
            KerberosIV support: no
                   AFS support: no
                 S/KEY support: no
          TCP Wrappers support: yes
          MD5 password support: no
   IP address in $DISPLAY hack: no
      Use IPv4 by default hack: yes
       Translate v4 in v6 hack: yes

              Host: i386-redhat-linux-gnu
          Compiler: gcc
    Compiler flags: -O2 -march=i386 -mcpu=i686 -Wall
Preprocessor flags:
      Linker flags:
         Libraries: -lpam -ldl -lwrap -lz -lnsl  -lutil  -lcrypto

Pekka Savola                  "Tell me of difficulties surmounted,
Netcore Oy                    not those you stumble over and fall"
Systems. Networks. Security.   -- Robert Jordan: A Crown of Swords

More information about the openssh-unix-dev mailing list