FAQ 3.10

Ed Phillips ed at UDel.Edu
Mon Oct 8 23:55:27 EST 2001

I'm having trouble getting any sort of work-around for 3.10 on Solaris 8
with Sun's tcsh.  I've tried using "hup" to correct it but to no avail.
This problem wasn't present with ssh version 1 - it just seem to work.
Now we get all kinds of abandoned ssh processes lying around that have to
be manually killed.  Does anyone know if there is going to be a fix for
this problem or how to make it work correctly?

Here's an example of what I see when I run a remote xterm, and then close
it immediately:

polycut:~> ssh -n mahler xterm

<I immediately hit CTRL-d on the xterm and the the following error in the
original shell>

channel_lookup: 0: bad id: channel free
client_input_channel_req: channel 0: unknown channel

<I hit CTRL-c to get control of the original shell>

^CKilled by signal 2.



Ed Phillips <ed at udel.edu> University of Delaware (302) 831-6082
Systems Programmer III, Network and Systems Services
finger -l ed at polycut.nss.udel.edu for PGP public key

More information about the openssh-unix-dev mailing list