AIX - Compilation issues with openssh

j.petersen at j.petersen at
Thu Oct 18 01:06:19 EST 2001

Hello Developers/users @AIX,

My Question:
What compiler and what configure-Options do you use to build the

My Problem:
   Logging in via self-built sshd:  no problem
but when doing a second "ssh"-step to another host, the tty 
is messed up: 
		 jp $ su -
echos:	 su -
		 [and Password is visible... and cursor keys don't work...]
Problem occurs only when the first step of successive "ssh"'s is
	from Putty (SSH-2) or TeraTerm (SSH-1) to the self-compiled
sshd at AIX...
	Any other combination works fine.

   openssh-Binaries from Linux-Toolbox and from Bull work nice.
However, I need --with-tcp-wrapper enabled and AIX432.

I tried:
   a) recent daily Snapshots (worked fine with solaris 2.4,2.5,2.6,2.7)
   b) IBMs openssh-2.9.9p2-3.src.rpm
   1) C-Compiler ibmcxx.rte from IBM
   2) gcc 2.95.2 (binaries from bull)
   A) AIX-432-ML2
   B) AIX-433-ML8

   ./configure --prefix=/usr/local --with-prngd-socket=/dev/entropy
		 --with-default-path=... --with-mantype=man
--with-tcp-wrapper --with-ssl-dir=...
   (SSL was mainly freeware.openssl.rte. binary from Bull)

Seems I'm the only AIX-user having this problem???
Must be my compiler(s!), libraries, ... ???

Having no clue how to debug this...

Thanks Jörg

More information about the openssh-unix-dev mailing list