OpenSSH-3.5p1: sshd fails at run-time

Jacob Schroeder jacob.schroeder at
Fri Dec 13 05:17:07 EST 2002

Doh!  haha, I can't believe I didn't even notice that.  Cool, that helped, I
am getting a little farther, I disabled the Compression, then I was still
having problems where as soon as I would connect, I would get disconnected
by the server as I've shown below (***Compression disabled).  However, if I
disabled just PriveligeSeparation, then it worked as it should.  I'd still
like to find a way to enable PrivSep because that sounds important, but I
realize LynxOS is quite limited, and the way I see it... any ssh w/o PrivSep
is much better than telnet.

Thanks a lot for your guys' help.  I'll be sending the info from config.log
so you guys can see what I've got here.  It's down there... quite a few

I think I'm going to also try Ben Lindstrom's suggestion dealing with
HAVE_MMAP in config.h to see if I get the same result (theoretically I
should).  I have to try to find a way to make the installation simple so I
can get this spread across several of our LynxOS machines.

Thanks for all your help!  I may be emailing the list again here in a bit
once I do some more experimenting, thanks a million!


***Compression disabled
debug1: channel 1: new [auth socket]
debug1: server_input_channel_req: channel 0 request pty-req reply 1
debug1: session_by_channel: session 0 channel 0
debug1: session_input_channel_req: session 0 req pty-req
debug1: Allocating pty.
debug3: mm_request_send entering: type 25
debug3: mm_pty_adebug3: monitor_reald: checking requestl 25
debug3: mm_ansower_pty entering
dcebug1: session_new:a init
eebug1: sesstion_new: session 0
: waiting for MONITGetting tty modes fOor pty failed: TermRinal device
debug3: mm_requeAst_send entering: tNype 26
mm_send_fd:S sendmsg(4): Socket_ operation on non-sPocket
debug1: CallTing cleanup 0x12964Y(0x40cda4)
p: session 0 releasde /dev/ttyp3
ebug3: mm_request_receive_expect entering: type 26
debug3: mm_request_receive entering
mm_receive_fd: recvmsg: Socket operation on non-socket
debug1: Calling cleanup 0xf940(0x41b510)
debug1: temporarily_use_uid: 1113/11 (e=1113/11)
debug1: restore_uid: (unprivileged)
debug1: Calling cleanup 0x1f254(0x0)
debug1: channel_free: channel 0: server-session, nchannels 2
debug3: channel_free: status: The following connections are open:
  #0 server-session (t10 r0 i0/0 o0/0 fd -1/-1)

debug3: channel_close_fds: channel 0: r -1 w -1 e -1
debug1: channel_free: channel 1: auth socket, nchannels 1
debug3: channel_free: status: The following connections are open:

debug3: channel_close_fds: channel 1: r 10 w 10 e -1
debug1: Calling clbash-2.02# eanup 0x1a78c(0x0)

## --------- ##
## Platform. ##
## --------- ##

hostname = schmidts
uname -m = i386
uname -r = 3.1.0
uname -s = LynxOS
uname -v = 071000-F

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = unknown
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
hostinfo               = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/users/jacob/bin
PATH: /usr/local/bin
PATH: /lat/bin
PATH: /bin
PATH: /lat/techbin

>-----Original Message-----
>From: David M. Williams [mailto:d_wllms at]
>Sent: Wednesday, December 11, 2002 5:09 PM
>To: Jacob Schroeder
>Cc: 'openssh-unix-dev at'
>Subject: Re: OpenSSH-3.5p1: sshd fails at run-time
>remove the #'s before Compression and UsePriviledgeSeperation.  The # 
>symbol makes the line a comment.

More information about the openssh-unix-dev mailing list