[Bug 109] New: sftp hangs when a tcsh user types quit or exit

bugzilla-daemon at mindrot.org bugzilla-daemon at mindrot.org
Tue Feb 12 08:11:28 EST 2002


           Summary: sftp hangs when a tcsh user types quit or exit
           Product: Portable OpenSSH
           Version: 3.0.2p1
          Platform: UltraSparc
        OS/Version: Solaris
            Status: NEW
          Severity: normal
          Priority: P2
         Component: sftp
        AssignedTo: openssh-unix-dev at mindrot.org
        ReportedBy: andrewb at cs.mcgill.ca

When using sftp I found that when quiting the application, it would hang. It
exits when one does a ^C. I checked my .cshrc to make sure that ignoreeof was
not set or anything else that could be preventing me from exiting. I did the
test recommended for sftp/scp in the FAQ, that works at it should. I then asked
a co-worker to try and he had no problems. The difference between our 2 accounts
was that I use tcsh and he uses bash. I then set my shell to bash, and quit
worked without any problems.

Below is the output from running sftp in verbose mode:

sftp> version
SFTP protocol version 3
sftp> quit
debug1: channel 0: read<=0 rfd 4 len 0
debug1: channel 0: read failed
debug1: channel 0: input open -> drain
debug1: channel 0: close_read
debug1: channel 0: input: no drain shortcut
debug1: channel 0: ibuf empty
debug1: channel 0: input drain -> closed
debug1: channel 0: send eof
debug1: channel 0: rcvd eof
debug1: channel 0: output open -> drain
debug1: channel 0: obuf empty
debug1: channel 0: output drain -> closed
debug1: channel 0: close_write
debug1: channel 0: send close
debug2: channel 0: no data after CLOSE
debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: channel 0: rcvd close
debug2: channel 0: no data after CLOSE
debug1: channel 0: is dead
debug1: channel_free: channel 0: status: The following connections are open:
  #0 client-session (t4 r0 i8/0 o128/0 fd -1/-1)

debug1: channel_free: channel 0: dettaching channel user

Killed by signal 2.
debug1: Calling cleanup 0x805a760(0x0)
debug1: Calling cleanup 0x8063370(0x0)

I also downloaded and tried the snapshot of : openssh-SNAP-20020211.tar.gz
That had the same problem.

If any of you need more information please let me know.


------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the openssh-unix-dev mailing list