ssh works fine, scp fails

Martin Pitt martin at
Sun Jun 15 18:01:50 EST 2003

Hi openssh developers!

I have the following problem: ssh works very fine, but scp fails as
soon as it wants to start the actual transfer:

--------------- screenshot ------------------
martin at donald:/home/martin$ scp -v -v -v joke mpitt at
debug1: Authentication succeeded (publickey).
debug1: fd 4 setting O_NONBLOCK
debug1: fd 5 setting O_NONBLOCK
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug1: Entering interactive session.
debug2: callback start
debug2: ssh_session2_setup: id 0
debug1: Sending command: scp -v -t .
debug1: channel 0: request exec
debug2: callback done
debug1: channel 0: open confirm rwindow 0 rmax 32768
debug1: channel_free: channel 0: client-session, nchannels 1
debug3: channel_free: status: The following connections are open:\015
  #0 client-session (t4 r0 i0/0 o0/0 fd 4/5)\015

debug3: channel_close_fds: channel 0: r 4 w 5 e 6
debug1: fd 0 clearing O_NONBLOCK
debug1: fd 1 clearing O_NONBLOCK
Read from remote host Connection reset by peer
debug1: Transferred: stdin 0, stdout 0, stderr 59 bytes in 0.2 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 254.7
debug1: Exit status -1
lost connection
--------------- screenshot ------------------

Something at my new internet provider is different, since it worked
with my old one (maybe they are filtering away some important ICMP
packages). But I'm asking here since scp2 from the commercial version
3.2.3 works, thus there must be a solution within scp.

I have already tried the following without success:

- setting the ethernet card MTU of the local/remote/both ends to a
  very small value (200)
- adding the TCPMSS iptables rule to my firewall to remedy a possible
  filtering of ICMP 'Fragmentation needed' packets
- FTP, HTTP, IMAP with large attachments are working correctly, so I
  doubt that it has sth. to do with too big packets
- piping over ssh with "echo Hello | ssh mpitt at 'cat > x'"
  which fails with exactly the same error.

I would be grateful for any hints (or patches ;-) ). IMHO it would be
nice to have OpenSSH as powerful as the commercial one.

Thanks for your great work and have a nice day!


P.S. Please Cc: me, I am not subscribed.
Martin Pitt
eMail: martin at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : 

More information about the openssh-unix-dev mailing list