Error on Reliant Unix: no controlling terminal

Stephan Hendl Stephan.Hendl at
Mon May 26 21:54:33 EST 2003

Hi Darren,

thank you - now it works!!!

The System is a

root at soltest: uname -a
ReliantUNIX-N soltest 5.45 B1007 RM400 1/256 R4000

The system is a Sys-V, R4 derivate, similiar to ealier Solaris versions.

Thanks oncemore

LDS Brandenburg
Dr. Stephan Hendl
fon: +49-(0)331-39 471
fax: +49-(0)331-27548 1187
mobil: +49-(0)160-90 645 893
EMail: stephan.hendl at

>>> Darren Tucker <dtucker at> 05/26 11:47  >>>
Stephan Hendl wrote:
> just I tried to upgrade openssh from 3.5p1 to 3.6.1p2 on Reliant Unix 5.45 and run into this error:
> root at soltest: tail /var/adm/log/messages
> ....
> May 23 15:45:28 soltest unix: sshd[4013]: Accepted password for root from port 2624 ssh2
> May 23 15:45:28 soltest unix: sshd[4101]: error: setsid: Not owner
> May 23 15:45:28 soltest unix: sshd[4101]: error: open /dev/tty failed - could not set controlling tty: No such device or address

Try adding "#define STREAMS_PUSH_ACQUIRES_CTTY 1" to config.h and

Is Reliant a Sys-V derivative?  We might need to to add it to the list of
broken pty implementations.  See [1] for the gory details.


Darren Tucker (dtucker at
GPG Fingerprint D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

More information about the openssh-unix-dev mailing list