Problem running SSH on IBM PPC440 processor, help appreciated

Chahine, Nagib N Nagib.N.Chahine at
Tue Nov 25 07:50:29 EST 2003

I am not able to tell whether it is decripted correctly, however as you see from the messages, I know the connection is established correctly, one message is received and decoded correctly since the checksum matches, howver one message coming from the server with length 5 bytes gets handled incorrectly by the client which yields to a bad checksum.
Any ideas??


-----Original Message-----
From:	Markus Friedl [mailto:markus at]
Sent:	Mon 11/24/2003 9:44 AM
To:	Chahine, Nagib N
Cc:	openssh-unix-dev at
Subject:	Re: Problem running SSH on IBM PPC440 processor, help appreciated
so is the packet decrypted correctly?

or are both the HMAC and the decrypted packet wrong?

In-Reply-To: <4543EA9DB1099E4583484B56803D0BFA0117FD71 at>

On Mon, Nov 24, 2003 at 08:19:33AM -0800, Chahine, Nagib N wrote:
> Hi,
> Sorry to bother you on this mailing list, however I tried everything else and I am desperate to get this running.  Please send me any hints you can think of.
> I have installed openssh-3.7.1p2 on a ppc target and trying to connect to an sshd running on a redhat 9 with openssh-3.5p1.  I keep getting the error "Disconnecting: Corrupted check bytes on input" no matter what I tried.  I located the error message and turned debugging on in packet.c which dumps the content of the packet.  What I see is a packet with length 5 bytes which confuses the client's side.  I tried running the sshd version 3.7.1p2 to match the client I keep getting the same error.

More information about the openssh-unix-dev mailing list