3.6p2 build errors on buffer_get with latest portable/SNAP

STEWARD, Curtis (Jamestown) Curtis.Steward at goodrich.com
Wed Sep 10 23:08:03 EST 2003

I've been running gcc 3.2, OpenSSL 0.9.7b and zlib 1.1.4.  After
receiving your reply I tried both OpenSSL 0.9.6.b and pulled
/usr/local/bin and /usr/local/sbin out of the PATH only
to get the same results.  I don't have any OS patches on 8.0,
so I can only guess I have something flakey on my box since
your up and running with the same release?  Let me know if 
you have any other ideas.



-----Original Message-----
From: Darren Tucker [mailto:dtucker at zip.com.au]
Sent: Tuesday, September 09, 2003 8:32 PM
To: STEWARD, Curtis (Jamestown)
Cc: 'openssh-unix-dev at mindrot.org'
Subject: Re: 3.6p2 build errors on buffer_get with latest portable/SNAP

"STEWARD, Curtis (Jamestown)" wrote:
> Tried the user discussion list to no avail, can't get 3.6.p2
> portable running due to buffer_get errors.  Does the
> latest portable SNAP incorporate the latest patches?

The snapshots contain everything committed to the CVS tree at the point
that they were generated.

> Running Red Hat 8.0
> /usr/local/sbin/sshd -t -f /usr/local/etc/sshd_config
> buffer_get: trying to get more bytes 1 than in buffer 0
> make: [check-config] Error 255 (ignored)

I build and test on Redhat 8 and I've never seen those errors.  What
versions of OpenSSL and zlib do you have?  Which version of gcc?

Darren Tucker (dtucker at zip.com.au)
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

More information about the openssh-unix-dev mailing list