3.6.1p1/SNAP-20030910, AIX & /etc/nologin (similar to bug #178)

David Bronder david-bronder at uiowa.edu
Wed Sep 17 03:19:23 EST 2003

Darren Tucker wrote:
> David Bronder wrote:
> > One thought I had about differences between my failing config and your
> > working config is compilers.  I'm using IBM's VAC compliler.
> I'm using gcc-3.3.
> In one of the 4.3.3 maintenance releases, IBM made some changes to the pty
> driver that caused some problems: from memory it was a zero-length write
> to the pty would result in a zero-length read on the pty, which sshd (and
> POSIX :-) interpret to mean a read failure.  Sshd would then close the
> session (since it thought the pty had closed).  This resulted in the
> session hanging.
> I'm wondering if it's related (and it makes me wonder about races hiding
> in the pty layer).

I knew there was a reason I didn't like mucking around with ptys.

> Hmm, timing.  What speed are your systems?  Mine's a 375 MHz 7043.

I'm doing my main testing on the same, but it doubles as my desktop, so
it's a little resource-starved (X, Netscape, etc.).  I've seen it occur
consistently on an idle box of the same class, though.

Just tried it on a 2x450 7026-H80 that's less loaded at this instant,
and everything worked like it should.  I know I've seen it hang on
higher-end boxes though.  I've also seen it work correctly, rarely, on
the 7043.


Hello World.                                    David Bronder - Systems Admin
Segmentation Fault                                     ITS-SPA, Univ. of Iowa
Core dumped, disk trashed, quota filled, soda warm.   david-bronder at uiowa.edu

More information about the openssh-unix-dev mailing list