patch to fix non-echo tty on scp SIGINT

Darren Tucker dtucker at
Wed Dec 8 19:18:54 EST 2004

Adam Wiggins wrote:
> All makes perfect sense, but the patch doesn't seem to change the
> behavior on my system (Linux, kernel 2.6, KDE 3.3 terminal).  Just for
> kicks I tried it on other terminals (xterm, gnome-terminal) on the same
> system - all give the same result.

I'm not able to reproduce that behaviour with the patch applied: I 
tested PuTTY, xterm and gnome-terminal (Linux 2.4.x) and PuTTY and xterm 
(Linux 2.6.x) and they all correctly restored the terminal echo mode.

Could you please re-test with, say, xterm, and if it still exhibits the 
problem, run the scp under strace -f and post the last 50 or so lines?

(Incidentally, on Linux, strace isn't ideal for debugging this kind of 
parent-child interaction since strace will change the behaviour of the 
processes slightly.  Don't ask how long it took to figure that out... )

Darren Tucker (dtucker at
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
     Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

More information about the openssh-unix-dev mailing list