"PAM rejected by account configuration" and "fatal: monitor_read: unsupported request: 24" problem at secong sshd instance

Darren Tucker dtucker at zip.com.au
Tue Jan 20 16:20:12 EST 2004

Istvan Viczian wrote:
> I setup two sshd instance (using OpenSSH_3.5p1 bins on redhat7.2  kernel 
> 2.4.20-19.7smp ) in order to achieve differnet sshd settings (e.g use 
> different auth.method) on two different network interfaces (both on port 
> 22).
> ( the second instance started with : sshd -f /etc/ssh2/sshd_config 
> without any problem)
> When I started the two daemon, the first instance
> ( which uses the default /etc/ssh conf. dir.)
> always worked properly (login from host as user2)
> independently form the used auth. method
> , but the second daemon always failed after the successfull 
> authentication with
>   "PAM rejected by account configuration[]: User account has expired"
>   and
>   "fatal: monitor_read: unsupported request: 24"
> error messages (see detailed logs below ).

PAM thinks the account has expired.  Check it with "chage -l 
accountname" and if it is, unexpire it ("chage -E" I think, check the 
man page).

> I also tried to run only the second instance, and the same problem
> appeared! So it seems for me that the problem is reduced to using non 
> default sshd config file!

I suspect that your first sshd was compiled without PAM support and the 
second was compiled with it.

Darren Tucker (dtucker at zip.com.au)
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
     Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

More information about the openssh-unix-dev mailing list