SSHD creates defunct process

Chidanand Gangur chidanand.gangur at
Wed May 11 00:25:53 EST 2005


I am using on sshd version OpenSSH_3.6.1p2.

I am facing some very vauge problem when i run sshd server and try to
connect to it.

When I run sshd in debug mode [ ./sshd -ddd]  I am able to connect to
it and every thing functions very well, but when i run it as [./sshd] 
and try to connect it the connection hangs creating defunct process.
The entries in process table are

25571 ?        S      0:00 sshd: admin [priv]
25573 ?        Z      0:00 [sshd <defunct>]

I have propretory PAM module which hooks in my authentication
mechanism to sshd. Based upon my pam module logs and sshd debug
messages i can say that authentication went on smoothly and it
returned PAM_SUCCESS to do_pam_authenticate. After this the shell just

I can see  this error in var log messages when run either by [ ./sshd
-ddd] or  [./sshd]

PAM [dlerror: /lib/security/$ISA/ cannot open shared
object file: No such file or directory]

My /etc/pam.d/sshd looks like this

 auth       sufficient   /scratch/Chidanand/bagini-p2/lib/
 account    required     /scratch/Chidanand/bagini-p2/lib/
 password   required service=system-auth
 session    required     /scratch/Chidanand/bagini-p2/lib/

I am confused with this problem, can any one  help me to nail down this issue.

Chidanand Gangur

More information about the openssh-unix-dev mailing list