SSHD creates defunct process

Chidanand Gangur chidanand.gangur at
Wed May 11 16:11:44 EST 2005

I tried to trace SSHD using strace -fF as said before SSHd waits in
select loop. When i connect I do not get login prompt to proceed

regarding PAM unable to dlopen(/lib/security/$ISA/
the file exists in that location.

$ISA  is not initialised that contains nothing. I have also tried hard
codding the file path in system-auth file, still i see the above error
in /var/log/messages.

I also tried Darrens pam-test-harness program, all of my test went
through. [thanks Darren] With this test i could see my authentication
request comming to my authentication module getting authenticated and
returning success to my pam module.

All these functions returned SUCCESS
pam_set_item(pamh, PAM_TTY
pam_set_item(pamh, PAM_RHOST,
pam_set_item(pamh, PAM_RUSER,
pam_authenticate(pamh, 0)
pam_acct_mgmt(pamh, 0)
pam_open_session(pamh, 0)
pam_setcred(pamh, 0)
pam_get_item(pamh, PAM_USER, ...)

PAM_USER = testcng (unchanged)

Standard environment variables
PAM environment variables

uid 0 euid 0 gid 0 egid 0
pam_end(pamh, 0) = 0 (Success)

But the [sshd <defunct> ] problem still persists. when SSHD started as [./sshd].

To add more information i am using gcc-v3.2.2

On 5/11/05, Darren Tucker <dtucker at> wrote:
> Peter Stuge wrote:
> > On Wed, May 11, 2005 at 12:17:34AM +0530, Chidanand Gangur wrote:
> >>When started with strace SSHD waits in select loop.
> >
> > Ok, so you're on Linux.
> > Try strace -fF sshd -D
> Be aware that strace on Linux will change some of the behaviour of the
> parent/child relationships, so while it may help it's not an ideal
> diagnostic.
> [and from the original posting]
>  >> PAM [dlerror: /lib/security/$ISA/ cannot open shared
>  >>object file: No such file or directory]
> It looks like you are missing the file, or the path is wrong
> in /etc/pam.d/system-auth.
> >>I have placed various log messages in sshd source code .what  I can
> >>see  is after calling do_pam_converse  function from do_pam_account
> >>function sshd does nothing. that is creates zombie.
> >
> > Hm, I'm not too familiar with the workings of the PAM but perhaps the
> > trace output could help nail the problem down.
> There's a bug in some versions of LinuxPAM that prevents an app from
> changing of the conversation function.  It's possible that PAM is
> calling the wrong conversation function:
> I wrote a tool for figuring out what PAM is doing underneath the covers,
> based in part on sshd's PAM interface code.
> It's available here:
> The documentation, such as it is, is here:
> --
> Darren Tucker (dtucker at
> GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
>      Good judgement comes with experience. Unfortunately, the experience
> usually comes from bad judgement.
> _______________________________________________
> openssh-unix-dev mailing list
> openssh-unix-dev at

Chidanand Gangur

More information about the openssh-unix-dev mailing list