SSHD creates defunct process

Peter Stuge stuge-openssh-unix-dev at
Thu May 19 00:19:33 EST 2005


I'll chip in here, even if I'm no PAM guru.

On Wed, May 18, 2005 at 05:33:16PM +0530, Chidanand Gangur wrote:
> I have got fresh source of  openssh-3.6.1p2 . I compiled it with
> --with-pam option. I have my .

3.6.1p2 is really old and many PAM improvements are in the latest
release 4.0p1.

> With the same set up as mentioned above I have every thing working
> fine on one of my test machines which has RH9 installed . But the
> same set up on another machine with same configuration same OS RH9
> fails to work.
> I get following messages :
> May 18 16:53:44 vml1ravid sshd: PAM unable to
> dlopen(/build/release-cp/
> May 18 16:53:44 vml1ravid sshd: PAM [dlerror:
> /build/release-cp/ undefined symbol: pdp_module_props]
> May 18 16:53:44 vml1ravid sshd: PAM adding faulty module:
> build/release-cp/

This tells me that there's a problem in your PAM module,
which tries to load the symbol pdp_module_props from, but
that load fails.

> When I run Darrens pam-test-harness -u testcng -s sshd
> I get following  response:
> conversation struct {conv=0x8048d6d, appdata_ptr=0x804b064}
> pam_start(sshd, testcng, &conv, &pamh) = 0 (Success)
> pam_set_item(pamh, PAM_TTY, "/dev/pts/2") = 0 (Success)
> pam_set_item(pamh, PAM_RHOST, "") = 0 (Success)
> pam_set_item(pamh, PAM_RUSER, "chidanandgangur") = 0 (Success)
> pam_authenticate(pamh, 0) = 6 (Permission denied)

Since I don't know PAM very well I can't say if this means that the
authentication just failed because of invalid credentials or if there
was an internal error in a PAM module.

> When I run SSHD in debug mode i get following debug messages

Looks like sshd exits or hangs abruptly. That could be a consequence
from the PAM module failing somehow, right?

More information about the openssh-unix-dev mailing list