Problems after having crosscompiled for XScale

Rogier Stam rogier at
Sun Jun 11 14:58:18 EST 2006

Darren Tucker wrote:

> Rogier Stam wrote:
>> I tried porting OpenSSH-4.3p2 to arm-linux (IXP425 Xscale platform) > 
>> using openssl-0.9.8b and uClibc. This on the snapgear 3.2.0 
>> distribution. It all compiles without problems, but when i run any 
>> openssh executable it will always show output similar to the following:
>> # ssh
>> sh: /usr/bin/ssh: No such file or directory
>> #
>> I checked for the libraries, they are all in /lib. To give you an ls:
> [list of libs]
> seems to be missing.
> If that's not it, do you have ldd on your target, and if so what does 
> ldd /usr/bin/ssh say?
I just managed to crosscompile ldd on my host platform. The result is 
the following:
root at RinceWind:/tmp/uClinux-dist/snapgear/uClibc/utils# ./ 
../../modules/openssh-4.3p2/sftp => not found (0x00000000) => not found (0x00000000) => /usr/lib/ (0x00000000) => not found (0x00000000) => not found (0x00000000) => not found (0x00000000) => not found (0x00000000) => not found (0x00000000)
        not a dynamic executable
Don't mind the not found messages, as it cannot find these libraries as 
the libraries are not in the system path yet, as i run ldd on the host 
not the target. This just to show what ldd says.
Symlinking to or /lib/ does not 
seem to solve the problem either.

More information about the openssh-unix-dev mailing list