Issue while Running SSH from a Windows Service

Nedunchezhian, Veena (TCS Consultant) Veena.Nedunchezhian.Consultant at
Thu Nov 30 11:00:02 EST 2006

Hi All - 
It seems to be an odd scenario. I have a simple ssh command which
establishes connection with a UNIX machine and executes some commands
over there. When I ran the command from command window, I was able to
successfully run them. In reality I wanted the ssh command to be invoked
by a windows 2003 service. I tried to debug the ssh command while
running from a service and I get the below log
C:\WINDOWS\system32>ssh -v -i c:\id_rsa -i c:\known_hosts -l stwdadmin "ls -rt /export/stwd/staged/ondemand/sqa/outbound/*.mf |
sed 's/\/export\/stwd\/staged\/ondemand\/sqa\/outbound\///g'>
OpenSSH_3.8.1p1, OpenSSL 0.9.7d 17 Mar 2004
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file c:\\id_rsa type 1
debug1: identity file c:\\known_hosts type -1
debug1: Remote protocol version 1.99, remote software version
debug1: match: OpenSSH_4.1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.8.1p1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY

After the above line, SSH hungs. Not sure where the problem is. I am
currently using SSH 3.8.1p1-1 version. 
Your support will be appreciated. !!!

Veena Nedunchezhian
Business Solutions Delivery - ACNielsen Retail Systems 
Phone: 847-605-5225 Mobile : 847-340-4051

Veena.Nedunchezhian.consultant at
<blocked::mailto:Veena.Nedunchezhian.consultant at> 


More information about the openssh-unix-dev mailing list