Creating a file by ssh

Cristian Nechita ncristin at
Mon Jan 1 00:27:03 EST 2007

I have this problem. I don't know if it's really a problem or just a 
misconfiguration of ssh.

I tried to copy from a Fedora 6 with rsync (via ssh) a file that has 
some italian characters inside (file it's named "qualità"). It gives me 
no error it copies the file but when I go to see it on the remote server 
(openSuse 10.2) i got this new file "qualit?" instead of "qualità". The 
same problem with the name of the folders.

I thought there has been an rsync problem but trying to vi a new file 
called "àèòàèù" by ssh (without rsync) to the same openSuse 10.2 I got 
the new file "???????". It's name is really made by the question mark 

I tried different version of ssh from Linux and WIndows (putty, ttssh, 
cygwin) but I have the same problem. I've tried creating the new file by 
ssh from an openSuse 10.2 to Redhat 7.2 and it's not working as well.

I've got surprised to see that from openSuse 10.2 (my laptop) to 
openSuse 10.2 (server) it's working fine. Such characters as "àòèù" I'm 
writing/reading well from both sides (local, and remote with ssh)

All my distro have the Italian keyboard installed and English language 
as default.

Thank you very much and have a great New Year
Cristian Nechita
P.S. I've posted this question on but I did not have any 

More information about the openssh-unix-dev mailing list