Creating a file by ssh

Cristian Nechita ncristin at
Mon Jan 1 05:33:45 EST 2007

   Thank you very much BOB.
   You're right about the file. The source and the destination it's
   similar (md5sum). It's only the file name that's changed.
   I think you're right with the variables too. I have to check the
   local/remote variables to see what's changed between them.
   I'm very disappointed (at this point) of this project cause I wanted
   it as partial portability Backup WareHouse. Using openSuse 10.2  as
   server and Windows (.NET 2), Linux Fedora ( Ubuntu yet not tried ) as
   client. The whole worked smooth and clear until this characters.
   I wanna thank you another time for being so quickly.
   Have a great New 2007 Year.
   Bob Proulx ha scritto:

Cristian Nechita wrote:

I have this problem. I don't know if it's really a problem or just a 
misconfiguration of ssh.

I think you are getting confused by thinking that the copy is not
working.  But I think the copy is working fine and it is the other
components of your system, specifically the locale information, that
is different.


I tried to copy from a Fedora 6 with rsync (via ssh) a file that has 
some italian characters inside (file it's named "qualità"). It gives me 
no error it copies the file but when I go to see it on the remote server 
(openSuse 10.2) i got this new file "qualit?" instead of "qualità". The 
same problem with the name of the folders.

I thought there has been an rsync problem but trying to vi a new file 
called "àèòàèù" by ssh (without rsync) to the same openSuse 10.2 I got 
the new file "???????". It's name is really made by the question mark 

You can check that the file contents were copied correctly by
comparing the message digest (aka checksum) of the files.

  md5sum filename
  sha1sum filename

If the message digests are the same on both systems then you can be
assured that the file contents were copied correctly between the
systems.  I am guessing the the file contents have been copied

The first thing you should check to get to the root of the problem is
what locale data is available on the different systems and what your
locale configuration is set to use.  One useful command is 'locale'
that prints out the locale environment variables.


That prints the environment variables but does not say anything about
whether the needed locale data is actually installed.  I don't know
how to get that information portably.  On my Debian system the list of
installed locales is in the /etc/locale.gen file and may be easily
reconfigured using the 'sudo dpkg-reconfigure locales' command.

I am confident that the problem is that between these two systems you
do not have the same locale configuration or the system does not have
all of the locale data installed.


I've got surprised to see that from openSuse 10.2 (my laptop) to 
openSuse 10.2 (server) it's working fine. Such characters as "àòèù" I'm 
writing/reading well from both sides (local, and remote with ssh)

Both sides have the desired locale data installed and have the same
locale configuration.


More information about the openssh-unix-dev mailing list