openssh ssh_askpass problem / question

Alphenaar, Jan jan.alphenaar at
Wed Jul 25 22:52:19 EST 2007


I have tried both options

SSH_ASKPASS=<path with space in one of the directories>
SSH_ASKPASS="<path with space in one of the directories>"

But each of them is giving me the same error message, as indicated in my
original email.

Warm Regards,


-----Original Message-----
From: at
[ at mindrot.
org] On Behalf Of Peter Stuge
Sent: Wednesday, July 25, 2007 2:42 PM
To: openssh-unix-dev at
Subject: Re: openssh ssh_askpass problem / question

On Wed, Jul 25, 2007 at 09:27:46AM +0100, Alphenaar, Jan wrote:
> This indicates that openssh executes the askpass program with an
> absolute path, without decently quoting the string. I am using the
> cygwin implementation of openssh, currently version 4.6p1.

Try adding quotes to SSH_ASKPASS yourself.

I don't know if this is a problem in OpenSSH or Cygwin.

openssh-unix-dev mailing list
openssh-unix-dev at
The information in this email is confidential and may be legally privileged. Access to this email by anyone other than the intended addressee is unauthorized. If you are not the intended recipient of this message, any review, disclosure, copying, distribution, retention, or any action taken or omitted to be taken in reliance on it is prohibited and may be unlawful. If you are not the intended recipient, please reply to or forward a copy of this message to the sender and delete the message, any attachments, and any copies thereof from your system.
BearingPoint B.V.
statutaire zetel: 's-Gravenhage
Dossiernummer: 30142784 Kamer van Koophandel Amsterdam

More information about the openssh-unix-dev mailing list