Openssh4.6p1 Make tests failed in sftp

John Wong jwwong at
Fri Sep 7 05:02:56 EST 2007

Hi Darren,

I tested 4.7p1 and got the same error in sftp of "make tests".

I made the following changes before applying the configure command:
- change to
- add /soamp/SSCommon/GCC/gcc3.3/bin to $PATH (setup the PATH to GCC)
- setenv LD_LIBRARY_PATH /soamp/SSCommon/GCC/gcc3.3/lib 
- setenv PERL /opt/corp/unsupported/bin/perl5
- setenv INSTALL "/opt/corp/unsupported/bin/ginstall -c"
- setenv CFLAGS "-g -02 -0 -mcpu=ultrasparc"

The configure command I used was:
./configure --prefix=/opt/openssh --without-zlib-version-check
--with-ssl-dir=/vobs/OpenSSL/0.9.8e/loadbuild/SunOS_5.10 --with-pam

I used "without-zlib-version-check" because the version of zlib in my
machine is 1.1.3, but I don't think this would cause the sftp problem.

Hope that may help in finding the cause of the problem.


-----Original Message-----
From: Darren Tucker [mailto:dtucker at] 
Sent: Wednesday, September 05, 2007 7:29 PM
To: Wong, John (CAR:CP04)
Cc: openssh-unix-dev at
Subject: Re: Openssh4.6p1 Make tests failed in sftp

John Wong wrote:
> After configuring and compiling OpenSSH version 4.6p1 in my SUN 
> Solaris8 ultrasparc machine, I run "make tests" and got the following 
> errors. The compiler used is GCC3.3.

4.7p1 was just released in the last day or so.  Could you please repeat 
the tests with that version?  I test on Solaris 8/sparc regularly so 
there's no fundamental reason why it shouldn't work.

> I do not get these errors when running "make tests" with OpenSSH 
> version 4.3p2 in the same machine.
> When I installed the 4.6p1 package to my machine and test sftp from a 
> client, I got the following log messages in the authlog:
> Sep  5 17:09:51 wcarsx0h sshd[23483]: subsystem request for sftp Sep  
> 5 17:09:56 wcarsx0h sftp-server[23840]: error: process_write: write 
> failed Sep  5 17:09:56 wcarsx0h sshd[23483]: error: channel 0: 
> chan_read_failed for ist

These are spurious and can be ignored.  They are fixed in 4.7p1.

> Further debugging on process_write of sftp-server.c, I found that the 
> errno returned from the "write" function is always "File too large" no

> matter what is the size of the file. I appreciate your help to further

> investigate the possible casue of the problem.

I'm wondering if configure some how got something like large file 
support wrong... Could you please post the content of config.h (eg "grep

'#define' config.h" to strip out the comments and blanks).  Also, what 
CFLAGS are set in the Makefile?


Darren Tucker (dtucker at
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
     Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

More information about the openssh-unix-dev mailing list