Hanging ssh sessions with openssh-5.1p1 and Solaris 8 & 10

Jeff Wieland wieland at purdue.edu
Tue Aug 5 04:34:23 EST 2008

Since we upgraded OpenSSH from 5.0p1 to 5.1p1 on our Solaris 8 boxes
(I know, I know, we should upgrade or retire them...), we've started
experiencing problems with slogin'ing into these boxes, running vi,
and pasting text into the vi session.

As long as we are pasting in less that 1024 characters it's fine.
With >= 1024 characters, the session hangs.

If you run "/usr/ucb/lptest 72 23 | cat -n" in one window, and
then cut paste up to the "V" on line 13, things work as expected.
If you include the "W" on the line 13, the vi session will hang
with none of characters that are being pasted showing up.

We've been building OpenSSH with Sun Studio 11 -- I tried building
it with GNU-CC 3.4.4 with the same results.  We also link against
a locally built zlib, since Solaris 8 doesn't have zlib 1.2.3.
And we've used OpenSSL 0.9.8g and 0.9.8h with the same results.

We also tried building OpenSSH 5.1p1 on our Solaris 10 boxes using
Sun Studio 12, and we also get the hangs there.  The client doesn't
seem to matter -- we've seen it OpenSSH 5.1p1 from both Solaris
and Slackware Linux, and also from SecureCRT.

I have not been able to get anything useful from running sshd in
debug mode (at least, not that I recognize as useful :-) ).
           Jeff Wieland            |         Purdue University
    Network Systems Administrator  |        ITN&S Data Networks
        Voice: (765)496-8234       |        501 Harrison Street
         FAX: (765)494-6620        |   West Lafayette, IN 47907-2025

More information about the openssh-unix-dev mailing list