rsync problem after ssh upgrade

Alexander aledin at
Tue Aug 5 18:18:59 EST 2008


In my setup I collected logs from many hosts using ssh + rsync. It
worked fine untill I upgraded OpenSSH from version 5.0p1 to 5.1p1 on those 
hosts running Slackware Linux. After upgrade nothing works as before. When 
I try to get logs connection breaks with the following message in syslog
on the server side:

Aug  4 15:34:44 srvhost sshd[8130]: Accepted publickey for user from port 48421 ssh2
Aug  4 15:34:44 srvhost rsyncd[8136]: rsyncd version 2.6.9 starting, listening on port 873 
Aug  4 15:34:44 srvhost rsyncd[8136]: bind() failed: Permission denied (address-family 2) 
Aug  4 15:34:44 srvhost rsyncd[8136]: socket(10,1,6) failed: Address family not supported by protocol 
Aug  4 15:34:44 srvhost rsyncd[8136]: unable to bind any inbound sockets on port 873 
Aug  4 15:34:44 srvhost rsyncd[8136]: rsync error: error in socket IO (code 10) at socket.c(477) [receiver=2.6.9]

I see that port 873 is privileged and rsyncd can't bind to it. But it
could before upgrade! I tried to bind rsyncd to unprivileged port. It
works but not as expected. rsyncd starts in background, connection to
it through ssh doesn't occur and it continues to run in the background
even when I close ssh connection.

What the reason of such changed behaviour? How can I restore to what I 
have before?

authorized_keys on server:

command="rsync --daemon --config=/home/user/.ssh/rsyncd.conf",no-pty ssh-rsa AAAAB3Nz.......

rsyncd.conf on server:

path = /home/user/log
use chroot = false
read only = true

Server sshd_config:

Port 12345
AddressFamily inet
Protocol 2
DenyUsers baduser
UseDNS no
Subsystem	sftp	/usr/libexec/sftp-server

On client side a script uses this line to get logs:

rsync -v -e "ssh -q -T -p 12345 -l user -i ./key_logs_collector -o
'BatchMode yes' -o 'ConnectTimeout 30' -o 'StrictHostKeyChecking no' -o
'CheckHostIP no'" -zqt --max-size=100M  srvhost::logs/* logs/

Alexander Pravdin
aledin at

More information about the openssh-unix-dev mailing list