ssh 'connection reset by peer' problem since 5.8p1

dyle dyle at
Tue Mar 8 20:21:04 EST 2011


Sorry to interfere, but finally I find someone talking about my problem.

I encountered the very same problem with a mix of Gentoo/Ubuntu/Debian
machines whereas I could not connect from my Gentoo Box (5.8p1) to any
machine behind the firewall in the wild (Debian; 5.1p1). But connecting to
a Ubuntu box right next to me within the very same subnet and then SSH from
this very machine to a machine outside worked. I also could connect to any
machine inside the subnet from my Gentoo/5.8p1.

Then reducing the number of cypher-options on the client side by stating
in /etc/ssh/ssh_config:

--- 8< snip ---
#   Ciphers
Ciphers aes128-ctr,aes192-ctr,aes256-ctr,aes128-cbc,3des-cbc
#   MACs hmac-md5,hmac-sha1,umac-64 at,hmac-ripemd160
MACs hmac-md5,hmac-sha1,hmac-ripemd160
--- >8 snap ---

worked like charm. I finally can SSH again to my machines behind the

Thanks for this workaround.

KR, Oliver

More information about the openssh-unix-dev mailing list