AIX SFTP with chroot : conection closed without error message

Thierry CHARLES t.charles at
Thu Apr 3 02:21:46 EST 2014

I finally found an IBM document listing the whole procedure to make 
chroot on AIX
and ... It works ! :-) (SFTP and SSH too !)


Le 01/04/2014 13:39, Damien Miller a écrit :
> On Tue, 1 Apr 2014, Thierry CHARLES wrote:
>> Excuse me, I did a "ssh user at host" instead of "sftp user at host". That's why it
>> tried to open a tty.
>> So I tried again with SFTP and I got nothing more :'(
> Unfortunately I don't have an AIX system to help reproduce this.
> I'd suggest either running sshd under a debugger to see what is going
> wrong -or- adding some debug() calls to do_child() and
> sftp_server_main() to see where it is failing.
> _______________________________________________
> openssh-unix-dev mailing list
> openssh-unix-dev at

-------------- next part --------------
A non-text attachment was scrubbed...
Name: t_charles.vcf
Type: text/x-vcard
Size: 273 bytes
Desc: not available
URL: <>

More information about the openssh-unix-dev mailing list