Call for testing: OpenSSH 6.7

Corinna Vinschen vinschen at
Thu Aug 21 05:39:29 EST 2014

On Aug 20 11:34, Damien Miller wrote:
> On Tue, 19 Aug 2014, Corinna Vinschen wrote:
> > Maybe it was the fact that I called `cvs up' without the -d flag...?
> > 
> > Duh.  Sorry about that.
> :) no problem
> > So, now I can run the testsuite and I'm having a problem with the
> > "forwarding" test.  The older version of this test worked fine, the
> > latest from CVS sometimes fails:
> > 
> >   run test ...
> >   failed copy /bin/ls.exe
> >   cmp: EOF on /home/corinna/src/openssh/64bin/regress/copy
> >   corrupted copy of /bin/ls.exe
> [...]
> > Running the test another time, it runs to completion.  Running it
> > again, it fails.  It fails more often than succeeding, though.
> I've had problems with this test leaving a ssh or sshd (can't remember
> which right now) laying around after completion, which could interfere
> with future test runs. I thought I fixed it already, but maybe I didn't
> do so completely?

That may very well be the problem.  I reduced the forwarding script to
just starting sshd and then running the final "transfer over chained
unix domain socket forwards and check result" test loop, and it runs
fine every time.


Corinna Vinschen
Cygwin Maintainer
Red Hat
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <>

More information about the openssh-unix-dev mailing list