Private key (-i key_file) percent_expand problem when path contains percent sign (%)

Mikael Nordfeldth mmn at
Sat Apr 18 03:58:29 AEST 2015

I have problems ssh:ing with my private key when the user's.

I run Debian Jessie, with (other than whatever Debian has done)
non-modified OpenSSH:

   $ aptitude show openssh-client |grep Version:
   Version: 1:6.7p1-3

The problem is I get this fatal error without a remote connection being

   $ ssh user at
   percent_expand: unknown key %/

My $HOME is "/srv/www/".

If I give the full path to the directory with the -i parameter I get the
same error. If I provide a relative path, with `pwd` equal to $HOME, it
works just fine:

   $ pwd
   $ ssh -i /srv/www/ user at
   percent_expand: unknown key %/
   $ ssh -i .ssh/id_rsa user at
   The authenticity of host ''...

So it boils down to the -i parsing with a percent sign (which doesn't
expand) it seems. Anyone else experiencing this or can reproduce it?

Mikael Nordfeldth
XMPP/mail: mmn at
OpenPGP fpr: AE68 9813 0B7C FCE3 B2FA  727B C7CE 635B B52E 9B31

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the openssh-unix-dev mailing list