SCP fails with read failure on openssh6.5.

Roshan Nair roshanr.nair at
Fri Feb 20 23:16:42 AEDT 2015


Wanted to know if there is a work around or a fix available for the scp
failure issue we are seeing in atomicio6 func ? SCP code transfer starts
but in between gets stuck with read failure.

The linux version we have on our system is Linux (none)  and open
ssh version is OpenSSH_6.5p1, OpenSSL 1.0.1j.
Since its not possible for us to move to the latest linux kernel I am
trying to find a way for a fix.

The code flow is as below :

main() -> ..->sink()->atomicio6()->read()

In func atomicio6() returns response -1 with error number EAGAIN during the
course of the transfer.

Error number EAGAIN leads to a poll() being called which I believe never
returns and hence the scp transfer hangs.

I have tried enabling the macro BROKEN_READ_COMPARISION but no help.

I tried a solution mentioned in the thread below but that too didnt quiet

Anything else I can try to fix this or any workaround anyone can suggest ?

Roshan Nair

--whatever you end up doing ... love it!

More information about the openssh-unix-dev mailing list