Directory listing fails for specific user

Marcus Hann marcus.hann at
Fri May 27 17:20:01 AEST 2016

Hi Martin, 

Thanks for that, our problem was indeed that someone had edited .bashrc and had added echo lines to create a MOTD effect - having moved these to /etc/motd everything is working as expected now. 


----- Original Message -----

From: "Martin Hecht" <hecht at> 
To: "Marcus Hann" <marcus.hann at>, openssh-unix-dev at 
Sent: Tuesday, 24 May, 2016 6:54:00 PM 
Subject: Re: Directory listing fails for specific user 


we had a similar issue when one of our users has modified his .bashrc 
such that it was supposed to execute commands upon login, but they were 
called without absolute path and stored in non-default locations (i.e. a 
prior modification of the $PATH by profile.d was required). 
In an interactive bash a full profile was loaded and therefore it 
worked, but transferring files did not work, because that was not a 
login shell and thus the commands were not found and caused the error. 
Putting the commands into .profile instead of .bashrc solved the problem. 

That was Scientific Linux 6 (a RHEL clone), and I think it was with scp 
and not with sftp, but it might be related). 


On 20.05.2016 17:07, Marcus Hann wrote: 
> Hello, 
> We have recently had a new problem with one of the users on one of our servers. 
> Filezilla claims it connects and authenticates, but then fails to list the directory (although no error message is output, it just eventually times out. There is the full output of filezilla located here: 
> From the server side, the most verbose output I can make it print can be found here: I have set the debug level to DEBUG3 in the /etc/ssh/sshd_config line which now looks like: 
> Subsystem sftp /usr/libexec/openssh/sftp-server -l DEBUG3 
> And that is what came out. SSH works as expected for the user and I cannot think of anything that has changed that would cause it to stop working. 
> I do not get the same issue for other users on the same server. For example, the output of a working user connecting to the same server is: (filezilla) and (openssh). I'm at a complete loss as to what may be causing this and cannot find anyone on t'internet with the same issue. 
> Thanks in advance, 
> Marcus 
> _______________________________________________ 
> openssh-unix-dev mailing list 
> openssh-unix-dev at 

More information about the openssh-unix-dev mailing list