SSH Agent Forwarding Not Working (pkgoyq: message 2 of 17)

Tong Sun pkgoyq.xpt at
Thu Jul 12 15:03:44 AEST 2018

On Wed, Jul 11, 2018 at 11:53 PM Peter Moody wrote:
> > However, the forwarding doesn't seem to be actually working - "ssh -T
> > git at" works locally, but not if I run it on the server
> > (machine B). `ssh-add -l` prints fine locally, but prints "The agent
> > has no identities" on the server.
> it sounds like something on B is running a new ssh-agent process when
> you log in.
> when you ssh to B, is your $SSH_AUTH_SOCK owned by 'sshd' or
> 'ssh-agent'? if you've forwarded your agent, it should be owned by
> sshd on the remote host.


OMG! I've been trying to troubleshoot this problem for nearly **7**
years, and it now get solved just like that!

I launch keychain in my ~/.profile, which starts its own 'ssh-agent'.
Guess I'll remove it and start it manually only from machine A from
now on.

Thanks again Peter, I can't express how appreciate I am enough!

More information about the openssh-unix-dev mailing list