Help with ssh password pasting glitch

Kurt Fitzner kurt_opensshdev at
Mon May 3 00:54:45 AEST 2021

I suspect this problem is not with ssh itself, but I'm really at my
wit's end and don't know where else to ask. 

Requiring more stringent security for a new server,  I have for the
first time set up an ssh key with a password which I then store in
keepass.  If I log in once onto my remote server (call this one server
"A"), I can paste in the password and connect with no problem.  I can
log out, and back in, several times with no issue, each time pasting my
password in from keepass.  But if I log out, stay logged out for a
while, when I return I find I can no longer successfully paste in a key.
 It acts as if it's the wrong password.  If I manually type the
password, then I can log in.  And if I log back out, I can again paste
the key successfully.  This will work for a few hours, and then the
issue starts over. 

I tried using two keys.  Log into server A with key 1.  Log out.  Wait. 
When logging back in with a pasted password fails, I tried key 2. 
Pasting the password with key 2 also fails.  Typing in the password
manually with key 2 works.  And when I log back out, I can then paste in
password successfully with either key 1 or key 2.  For a while. 

The trick of typing in the password to get it to work again for a while,
it works only for server A.  By that, I mean, once I cannot paste in a
password to reach server A, if I ssh to server B, type in the password
manually, then exit, I still cannot paste in a password successfully to
get to server A.  I have to ssh to server A, manually type in the
password, connect, exit, then I can ssh back and successfully paste the
password again for a while. 

If I close the terminal window and start a new one, then I am also able
to successfully paste in a password for a time. 

I at first suspected something with ssh-agent, but disabling it has no

I wonder about something with the clipboard itself.  When ssh stops
working with a pasted password, I can paste the password onto the
terminal screen.  I can paste passwords into sudo.  It all works fine. 
But ssh doesn't work.  Neither does ssh-keygen.  For example, I can't
paste in the original password with ssh-keygen in order to change the

I quite at my wit's end on this.  Any suggestions would be appreciated.

More information about the openssh-unix-dev mailing list