[Bug 52] ssh hangs on exit

bugzilla-daemon at mindrot.org bugzilla-daemon at mindrot.org
Tue Feb 20 08:05:54 EST 2007


------- Comment #49 from tsi at ualberta.ca  2007-02-20 08:05 -------
(In reply to comment #48)
> (In reply to comment #47)
> > (In reply to comment #46)
> > > Yes, but that workaround doesn't need the patch. However, with
> > > latest patch, there is no hang when I run test2.ksh and exit from
> > > the shell on linux. But it is not the case with HP-UX. So Im
> > > wondering what the patch is doing with respect to HP-UX.

> > This is at odds with comment #26.

> I checked the testcases described in <A
> href="http://bugzilla.mindrot.org/show_bug.cgi?id=52#c35">comment
> 35</a> and they worked as described there for both HP-UX and Linux.
> But HP-UX behaves differently only when I login and launch my script
> described in <A
> href="http://bugzilla.mindrot.org/show_bug.cgi?id=52#c44">comment
> 44</a>. So I think there is something special that goes in HP-UX at
> login which is not happening when I just run with -t option. 

OK.  So, what happens if you do ...

  ./test2.ksh &

... when logged in?

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the openssh-bugs mailing list