[Bug 1278] CYGWIN controlMaster connections don't work.

bugzilla-daemon at mindrot.org bugzilla-daemon at mindrot.org
Tue Jan 30 03:12:52 EST 2007


           Summary: CYGWIN controlMaster connections don't work.
           Product: Portable OpenSSH
           Version: v4.5p1
          Platform: ix86
        OS/Version: Cygwin on NT/2k
            Status: NEW
          Severity: normal
          Priority: P2
         Component: ssh
        AssignedTo: bitbucket at mindrot.org
        ReportedBy: public.marvin at gmail.com

With this in my .ssh/config:
   ControlMaster auto
   ControlPath ~/.ssh/master-%r@%h-%p

I do (in one shell)
   ssh -Mnf REMOTE.HOST.NAME sleep 600
   <enter password>

In other shell

Master says:
mm_receive_fd: no message header 
 - - and exits
"Slave" says:
ssh_msg_recv: read: header
control_client: msg_recv
   - - and exits

Tried various permutations with -M, -S and nothing in config file,
same result.

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the openssh-bugs mailing list