[Bug 1567] Insufficient privileges to chroot() on AIX

bugzilla-daemon at bugzilla.mindrot.org bugzilla-daemon at bugzilla.mindrot.org
Fri Nov 20 23:19:57 EST 2009


--- Comment #12 from Cristi Terpea <cristi.terpea at fortech.ro> 2009-11-20 23:19:56 EST ---
I tested openssh-5.3p1 on 3 machines:
  AIX ... 1 5 004036AA4C00
  AIX ... 3 5 0040D7CB4C00
  AIX ... 1 6 0003EADAD300
on each of them I got the same result:
  debug3: safely_chroot: checking '/home/test'
  Changed root directory to "/home/test"
  Failed to set process credentials
then it quits.
I attached the truss log from AIX 6.1 (truss_log.txt)
I also attached the fix that worked for me (this code was posted
already in https://bugzilla.mindrot.org/attachment.cgi?id=1669 ). I
call setpcred before chroot.

Configure bugmail: https://bugzilla.mindrot.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching the assignee of the bug.
You are watching someone on the CC list of the bug.

More information about the openssh-bugs mailing list