[Bug 1813] New: Cannot compile on Mac OS X with non-default OpenSSL

bugzilla-daemon at bugzilla.mindrot.org bugzilla-daemon at bugzilla.mindrot.org
Wed Sep 1 16:52:59 EST 2010


           Summary: Cannot compile on Mac OS X with non-default OpenSSL
           Product: Portable OpenSSH
           Version: 5.6p1
          Platform: All
        OS/Version: Mac OS X
            Status: NEW
          Severity: minor
          Priority: P2
         Component: Build system
        AssignedTo: unassigned-bugs at mindrot.org
        ReportedBy: douglas at stebila.ca

I was trying to compile OpenSSH with a different OpenSSL installation. 
However, OpenSSH's ./configure command kept failing with the error
listed below.  I have included the full sequence of shell commands I

$ tar zxf openssl-1.0.0a.tar.gz
$ cd openssl-1.0.0a
$ ./Configure --prefix=/Users/dstebila/Downloads/dev/build
$ make
$ make install
$ cd ..
$ tar zxf openssh-SNAP-20100901.tar.gz
$ cd openssh
$ ./configure --prefix=/Users/dstebila/Downloads/dev/build
checking build system type... x86_64-apple-darwin10.4.0
checking OpenSSL header version... 1000001f (OpenSSL 1.0.0a 1 Jun 2010)
checking OpenSSL library version... 9080cf (OpenSSL 0.9.8l 5 Nov 2009)
checking whether OpenSSL's headers match the library... no
configure: error: Your OpenSSL headers do not match your
library. Check config.log for details.

I also tried adding LDFLAGS and CPPFLAGS to the ./configure command as
indicated below, but the same error occurred.

$ ./configure --prefix=/Users/dstebila/Downloads/dev/build

Configure bugmail: https://bugzilla.mindrot.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching the assignee of the bug.

More information about the openssh-bugs mailing list