[Bug 1869] ssh-add can no longer read from FIFOs as of 5.7p1

bugzilla-daemon at bugzilla.mindrot.org bugzilla-daemon at bugzilla.mindrot.org
Wed Mar 9 11:16:13 EST 2011


Jonatan Walck <jonatan at walck.se> changed:

           What    |Removed                     |Added
                 CC|                            |jonatan at walck.se

--- Comment #3 from Jonatan Walck <jonatan at walck.se> 2011-03-09 11:16:13 EST ---
I ran into the same bug using openssh-client 1:5.8p1-2 from debian sid
repo, also reproduced with a vanilla openssh 5.8p1 from an official
openssh mirror.

I found the error by using monkeysphere subkey-to-ssh-client, after
which ssh-agent did not add a new identity as expected.

Tried the attached patch and it works as expected again, identity added
and working for ssh. Would be great to see this patch included so FIFOs
start working again.

Configure bugmail: https://bugzilla.mindrot.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching the assignee of the bug.

More information about the openssh-bugs mailing list